Chercher dans la FAQ de Swizzonic

Arrêt de versions obsolètes de PHP

Mettez à jour votre version de PHP dans le compte utilisateur.
Les versions obsolètes de PHP seront désactivées.

Des anciennes versions de PHP sont marquées en rouge dans votre compte utilisateur dans les “Configurations de base” sous “Administration des produits”.

Elles seront éteintes par étapes à partir du 11 novembre 2020.

Pour les versions 5 et 7.0 de PHP, le support de la sécurité a déjà été interrompu. Pour PHP 7.1, le soutien actif n’était plus offert en décembre 2019. Vous pouvez trouver les versions actuelles supportées par php.net et leur roadmap sur le site de php.net.

» https://www.php.net/supported-versions.php

Oui. Si vous avez un produit actif WEB de Swizzonic, vous utilisez les fonctionnalités de PHP. Veuillez vérifier si vous avez déjà la dernière version. Si ce n’est pas le cas, nous vous recommandons de changer à la dernière version 7.3.6 dès que possible. Si des problèmes surviennent après la conversion, vous avez encore le temps de les résoudre jusqu’à l’arrêt.

A partir du PHP Version 5.2 (ascendent)
L’arrêt des versions 5.2 et supérieures de PHP commencera par étapes le 11 novembre 2020.

Pour changer la version de PHP, veuillez ouvrir les paramètres du domaine concerné dans la configuration de base. Sous Paramètres, vous pouvez sélectionner la version souhaitée dans la liste déroulante. Nous vous recommandons de passer directement à la version 7.3.6.

  1. Faites le login dans votre compte utilisateur sur swizzonic.ch
  2. Sous “Administration des produits” sélectionnez “Configuration de base” et en cliquant avec le bouton droit de la souris sur le domaine, cliquez “Ouvrir”, puis passez à l’onglet “Paramètres”.
  3. Ici vous avez un menu de sélection pour la version PHP.
    » Après le passage à une version actuelle, l’avertissement disparaît dans la configuration de base.

Si vous ne changez pas la version PHP dans votre compte utilisateur à une version PHP actuelle (à partir de 7.2), le système changera automatiquement à la version 7.2 à la date clé. Si vous utilisez un CMS à jour tel que WordPress, Joomla, etc., ceci est très probablement compatible. Il faut faire attention, surtout avec une programmation plus ancienne. En tel cas c’est possible que certains composants de votre site web ne fonctionnent plus correctement et vous devez les réparer.

N’hésitez pas à nous contacter si vous avez des questions. Notre service clientèle est à votre disposition: https://faq.swizzonic.ch